The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering
Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium.
Data as of 28 Oct 2026, 10:28 UTC
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| hwk-frAdvanced Custom Fields: Extended | Affected
| Fixed in– |
AI-suggested
A partial patch was introduced in version 0.9.2.4; however, versions up to 0.9.2.7 remain vulnerable. Users should upgrade to a version later than 0.9.2.7 once available that fully addresses the issue. Until then, restrict access to AJAX handlers or disable the plugin if possible. Monitor the vendor's advisory for official fixes and updates.
Description
The Advanced Custom Fields: Extended plugin for WordPress versions up to 0.9.2.7 contains multiple AJAX handlers accessible to unauthenticated users that lack proper authorization checks. These handlers expose cryptographic nonces generated for guest users, which are publicly visible on frontend pages using ACF forms. This allows attackers to bypass WordPress visibility permissions and access unauthorized data such as post titles and internal layout structures. A partial patch was introduced in version 0.9.2.4.
References
- nvd.nist.gov/vuln/detail/CVE-2026-2839 (opens in a new tab)
- plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-advanced-link.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-advanced-link.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-flexible-content-async.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-flexible-content-async.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3516027 (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3754818 (opens in a new tab)
- wordfence.com/threat-intel/vulnerabilities/id/9954ef37-bae0-48fb-9654-ff54750c46c2?source=cve (opens in a new tab)