Skip to main content
CVE-2026-4658VulnerabilityPublished

The Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to

Source GCVE Database

0
Authoritative record:CVE-2026-4658· Medium 6.4

Not known to be exploited · CVSS 6.4 Medium.

Data as of 27 Oct 2026, 00:52 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
wpdevteamGutenberg Essential Blocks – Page Builder for Gutenberg Blocks & PatternsAffected
  • <=6.0.4
Fixed in–

AI-suggested

Users should upgrade the plugin once a fixed version beyond 6.0.4 is released. Until then, restrict Contributor-level access and above to trusted users only. Monitor the vendor advisory for updates and apply official fixes promptly when available.

Description

The Essential Blocks WordPress plugin is vulnerable to stored cross-site scripting (XSS) via certain attributes in the Add to Cart block in versions up to 6.0.4. Authenticated users with Contributor-level access or higher can inject malicious scripts that execute when other users view the affected pages.

References

Community reviews

Loading reviews…