Skip to main content
CVE-2026-111978VulnerabilityPublished Updated

The GiveWP WordPress plugin before 4.19.0.1 does not properly validate a user-supplied filename before reading it from

Source GCVE Database

0
Authoritative record:CVE-2026-111978· Medium 6.0

Not known to be exploited · CVSS 6.0 Medium : upgrade to 4.19.0.1 when convenient.

Data as of 26 Oct 2026, 16:39 UTC

CVSS 3.1 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.19.0.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade GiveWP (WordPress plugin) to 4.19.0.1.

Affected software

ProductAffectedFixed in
GiveWPAffected
  • <4.19.0.1
Fixed in
  • 4.19.0.1

Description

The GiveWP WordPress plugin before 4.19.0.1 does not properly validate a user-supplied filename before reading it from disk, allowing users with a high-privilege custom role to perform path traversal, disclose the contents of JSON-parseable files anywhere on the server, and overwrite the GiveWP WordPress plugin before 4.19.0.1's stored configuration.

References

Community reviews

Loading reviews…