Skip to main content
CVE-2026-103875VulnerabilityPublished

The Media Library Assistant plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-103875· Medium 4.7

Not known to be exploited · CVSS 4.7 Medium.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Wordfence)CVSS 3.14.7
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
dglingrenMedia Library AssistantAffected
  • <=3.42
Fixed in–

AI-suggested

Users should verify if a fixed version beyond 3.42 is available from the plugin vendor or WordPress plugin repository. Until a fix is released, administrators should avoid exposing pages with the vulnerable shortcode configuration or disable the Media Library Assistant plugin if feasible. Monitor vendor advisories for updates. Since this is a reflected XSS requiring user interaction and specific configuration, limiting public exposure of affected pages can reduce risk.

Description

The Media Library Assistant plugin for WordPress versions up to and including 3.42 is vulnerable to reflected cross-site scripting (XSS) via the 'search-string' parameter. This vulnerability arises from insufficient input sanitization and output escaping, allowing unauthenticated attackers to inject arbitrary scripts. Exploitation requires a publicly accessible page with an [mla_gallery] shortcode configured with pagination output mode and an mla_link_href template reflecting a {+request:...+} token, plus enough attachments to trigger pagination. The CVSS score is 4.7, indicating medium severity.

References

Community reviews

Loading reviews…