Skip to main content
VulnerabilityPublished

CVE-2025-12180: The Qi Blocks plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-12180· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium · fixed in 1.4.4 : update affected systems when convenient.

Data as of 29 Oct 2026, 23:38 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.4.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

Since the vulnerability requires authenticated access at Contributor level or above, restricting user roles and permissions can reduce risk. Monitor vendor advisories for an official fix.

Description

The Qi Blocks plugin for WordPress up to and including version 1.4.3 has a Missing Authorization vulnerability. This flaw allows authenticated users with Contributor-level access or higher to inject arbitrary CSS via the REST API endpoint `qi-blocks/v1/update-styles`. The injected CSS can be used to manipulate the UI or exfiltrate information through CSS injection techniques.

References

Community reviews

Loading reviews…