Skip to main content
VulnerabilityPublished

CVE-2025-11229: The system fails to properly enforce scope authorization when the authorize_all_scopes configuration

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-11229· High 7.2

Not known to be exploited · CVSS 7.2 High : upgrade to 7.1.0.32 or 7.0.0.125 soon.

Data as of 4 Nov 2026, 07:29 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (WSO2)CVSS 3.17.2
Patch
Available – fixed in 7.1.0.32, 7.0.0.125, 7.8.23.49 +1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade WSO2 Identity Server to 7.1.0.32 or 7.0.0.125; WSO2 Identity Application Management Component to 7.8.23.49 or 7.0.78.137; org.wso2.identity.server/wso2-identity-server to 7.8.23.49, 7.1.0.32, 7.0.78.137 or 7.0.0.125.

Affected software

ProductAffectedFixed in
WSO2WSO2 Identity ServerAffected
  • >=7.1.0 <7.1.0.32
Fixed in
  • 7.1.0.32
WSO2WSO2 Identity ServerAffected
  • >=7.0.0 <7.0.0.125
Fixed in
  • 7.0.0.125
WSO2 Identity Application Management Componentorg.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.mgtAffected
  • >=7.8.23 <7.8.23.49
Fixed in
  • 7.8.23.49
WSO2 Identity Application Management Componentorg.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.mgtAffected
  • >=7.0.78 <7.0.78.137
Fixed in
  • 7.0.78.137
Mavenorg.wso2.identity.server/wso2-identity-serverpkg:maven/org.wso2.identity.server/wso2-identity-serverOther threatsAffected
  • >=7.0.0 <7.0.0.125
  • >=7.1.0 <7.1.0.32
  • >=7.0.78 <7.0.78.137
  • >=7.8.23 <7.8.23.49
Fixed in
  • 7.0.0.125
  • 7.1.0.32
  • 7.0.78.137
  • 7.8.23.49

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, it is recommended to keep the 'authorize_all_scopes' configuration disabled (its default state) to prevent unauthorized scope escalation. Review and restrict client credentials grant usage and monitor for any unauthorized access attempts related to scope authorization.

Description

CVE-2025-11229 is a vulnerability where the system does not properly enforce scope authorization when the 'authorize_all_scopes' configuration is enabled. This misconfiguration allows applications using the client credentials grant type to obtain all API scopes, including sensitive internal and console scopes, without explicit authorization. Exploitation can lead to privilege escalation, unauthorized administrative actions, access to confidential data, and potential full account takeover in affected deployments.

References

Community reviews

Loading reviews…