Skip to main content
CVE-2025-12175VulnerabilityPublished

The The Events Calendar plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-12175· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium · fixed in 6.16.0 : update all when convenient.

Data as of 29 Oct 2026, 23:29 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Affects
all up to 6.15.9
Patch
Available – fixed in 6.16.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

Since the vulnerability affects versions up to 6.15.9, users should monitor the vendor advisory for an official fix. If you cannot patch yet, consider restricting access to the plugin's AJAX endpoints or limiting Subscriber-level privileges if possible.

Description

The Events Calendar plugin for WordPress has a vulnerability in all versions up to and including 6.15.9 where a missing capability check on the 'tec_qr_code_modal' AJAX endpoint allows authenticated users with Subscriber-level access or higher to view draft event names and generate or view QR codes for those drafts.

References

Community reviews

Loading reviews…