CVE-2026-118552: drupal/ai · This module provides a framework for integrating AI providers and features into Drupal
Affects drupal/aiSource GCVE Database
Not known to be exploited : upgrade to 1.5.2 or 1.4.11 soon.
Data as of 28 Oct 2026, 20:43 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
- Patch
- Available – fixed in 1.5.2, 1.4.11
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade drupal/ai to 1.5.2 or 1.4.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagist https //packages.drupal.org/8drupal/ai | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading the Drupal AI module to version 1.4.11 or later, or 1.5.2 or later, as these versions contain the fix for the XSS vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
The Drupal AI module has a cross-site scripting (XSS) vulnerability due to insufficient sanitization of certain HTMX attributes. This flaw affects versions prior to 1.4.11 and versions from 1.5.0 up to but not including 1.5.2. Fixed versions 1.4.11 and 1.5.2 address this issue.