CVE-2026-101296: tomcat security update
Affects tomcatSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 9.0.123-1.oe2403sp3 as a priority.
Data as of 29 Oct 2026, 11:18 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0.123-1.oe2403sp3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade tomcat to 9.0.123-1.oe2403sp3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP3tomcatpkg:rpm/openEuler/tomcat&distro=openEuler-24.03-LTS-SP3Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache Tomcat installations to versions 11.0.27, 10.1.61, or 9.0.123, which contain fixes for all listed vulnerabilities. Applying these official updates is the primary and recommended mitigation. No alternative mitigations or workarounds are indicated in the advisory. Systems running end-of-life versions should be upgraded to supported fixed versions to ensure security.
Description
Multiple critical vulnerabilities have been identified in Apache Tomcat affecting versions from 7.0.0 through 11.0.26, including authentication bypass, request/response mix-up, failure to securely enforce FIPS mode, execution after redirect, local unauthorized access via TOCTOU race condition, and incomplete cleanup issues causing data leakage and TLS 1.3 connection failures. These vulnerabilities allow attackers to bypass authentication, cause data leakage between users, and potentially disrupt secure communications. Fixed versions are available and users are strongly advised to upgrade to 11.0.27, 10.1.61, or 9.0.123 to mitigate these issues.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4533 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-101296 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-101356 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-74048 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-74049 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-80353 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-88041 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-93446 (opens in a new tab)