Skip to main content
CVE-2026-53404VulnerabilityPublished Updated

Tomcat6: Always-Incorrect Control Flow Implementation vulnerability

Affects tomcat6Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-53404· High 7.3

Not known to be exploited · CVSS 7.3 High · fixed in 8.0.32-1ubuntu1.13+esm2 : patch tomcat6 soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.32-1ubuntu1.13+esm2, 8.5.39-1ubuntu1~18.04.3+esm6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu tomcat8 to 8.0.32-1ubuntu1.13+esm2 (package) or 8.5.39-1ubuntu1~18.04.3+esm6 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threatsAffected
  • 10.1.40-1ubuntu1 – 10.1.57~us1-0ubuntu1
7 affected builds
Fixed in–
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threatsAffected
  • 11.0.18-1 – 11.0.24-1ubuntu1
5 affected builds
Fixed in–
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threatsAffected
  • =9.0.115-1
  • =9.0.115-1ubuntu1
  • =9.0.118-1
Fixed in–
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threatsAffected
  • 9.0.95-1ubuntu1 – 9.0.118-1~26.04.1
5 affected builds
Fixed in–
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat's rewrite valve meant that if the first condition in an OR chain matched, subsequent non-OR conditions were skipped. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

References

Community reviews

Loading reviews…