CVE-2026-55955: Tomcat6 · Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the
Affects tomcat6Source GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 11.0.23 : update tomcat6 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.0.23
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
References
- ubuntu.com/security/CVE-2026-55955 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-55955 (opens in a new tab)
- github.com/apache/tomcat/commit/5e594400c7f6ac0eaf2526bd64442a70f5ccaace (opens in a new tab)
- github.com/apache/tomcat/commit/3a9ff01d2dfaca651edacbda3260e37b98b540d3 (opens in a new tab)
- github.com/apache/tomcat/commit/6a7a432cd7fb4ef358dc12e8da99cf3ab320f3fe (opens in a new tab)
- lists.apache.org/thread/g4p5sf45p3f9r011pwqs9r54yd64s106 (opens in a new tab)
- openwall.com/lists/oss-security/2026/06/29/24 (opens in a new tab)