Skip to main content
VulnerabilityPublished Updated

CVE-2025-66614: Tomcat8 · Improper Input Validation vulnerability

Affects tomcat8Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-66614· High 7.6

Not known to be exploited · CVSS 7.6 High · fixed in 11.0.15 : patch tomcat8 soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 25.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=questingOther threatsAffected
  • 10.1.35-1 – 10.1.40-1ubuntu1.25.10.1
4 affected builds
Fixed in–
Ubuntu 25.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=questingOther threatsAffected
  • =11.0.6-1
Fixed in–
Ubuntu 25.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=questingOther threatsAffected
  • 9.0.70-2ubuntu1.1 – 9.0.95-1ubuntu1.1
5 affected builds
Fixed in–
Ubuntu 24.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=nobleOther threatsAffected
  • 10.1.10-1 – 10.1.55-1ubuntu2~24.04.1
9 affected builds
Fixed in–
Ubuntu 24.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=nobleOther threatsAffected
  • 9.0.70-1ubuntu1 – 9.0.118-1~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did, it was possible for a client to bypass the client certificate authentication by sending different host names in the SNI extension and the HTTP host header field. The vulnerability only applies if client certificate authentication is only enforced at the Connector. It does not apply if client certificate authentication is enforced at the web application. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fix the issue.

References

Community reviews

Loading reviews…