Skip to main content
VulnerabilityPublished Updated

CVE-2026-65637: Tomcat8 · Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for

Affects tomcat8Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-65637· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 11.0.25 : patch tomcat8 as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.25
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threatsAffected
  • 10.1.40-1ubuntu1 – 10.1.57~us1-0ubuntu1
7 affected builds
Fixed in–
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threatsAffected
  • 11.0.18-1 – 11.0.24-1ubuntu1
5 affected builds
Fixed in–
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threatsAffected
  • =9.0.115-1
  • =9.0.115-1ubuntu1
  • =9.0.118-1
Fixed in–
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threatsAffected
  • 9.0.95-1ubuntu1 – 9.0.118-1~26.04.1
5 affected builds
Fixed in–
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat installations to versions 11.0.25, 10.1.58, or 9.0.121, which contain the official fix for this vulnerability. No other mitigation steps are indicated. Applying these updates will resolve the issue.

Description

An improper input validation vulnerability exists in Apache Tomcat due to an incomplete fix for a previous issue (CVE-2026-32990). This affects Apache Tomcat versions from 11.0.20 through 11.0.24, 10.1.53 through 10.1.57, and 9.0.115 through 9.0.120. The vulnerability has a critical severity with a CVSS score of 9.8. Users are advised to upgrade to versions 11.0.25, 10.1.58, or 9.0.121 where the issue has been fixed.

References

Community reviews

Loading reviews…