Twisted: Unauthenticated Remote Denial of Service
Affects TwistedSource GCVE Database
Mentioned vulnerabilities
CVSS 7.5 High : upgrade to 26.10.0rc1 soon.
Data as of 29 Oct 2026, 17:10 UTC
- Patch
- Available – fixed in 26.10.0rc1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HWhat to do
Upgrade Twisted to 26.10.0rc1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPITwisted | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Twisted version 26.10.0rc1 that addresses this vulnerability. Users should upgrade to version 26.10.0rc1 or later to remediate the issue. No other mitigations or workarounds are indicated in the advisory.
Description
An unauthenticated remote denial of service vulnerability exists in the Twisted HTTP/2 server due to improper handling of rapid stream resets. A remote client can send a request with END_STREAM followed immediately by a stream reset, causing the server to render the request fully before processing the reset. This allows repeated rapid resets on a single connection to exhaust CPU resources, bypassing the concurrent-stream limit. The issue affects Twisted versions prior to 26.10.0rc1 and has no impact on confidentiality or integrity.
References
- github.com/twisted/twisted/security/advisories/GHSA-vpp8-g58w-m8mp (opens in a new tab)
- github.com/twisted/twisted/pull/12749 (opens in a new tab)
- github.com/twisted/twisted/commit/498939422b69d5a75c4b8f81fa7926423dac534d (opens in a new tab)
- github.com/twisted/twisted (opens in a new tab)
- github.com/twisted/twisted/releases/tag/twisted-26.10.0rc1 (opens in a new tab)
- nvd.nist.gov/vuln/detail/cve-2023-44487 (opens in a new tab)