Skip to main content
VulnerabilityPublished

CVE-2026-14671: PostgreSQL module "refint" · Type Confusion

Source GCVE Database

0
Authoritative record:CVE-2026-14671· High 8.8

Not known to be exploited · CVSS 8.8 High · fixed in 18.6 : patch PostgreSQL soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.6, 17.11, 16.15 +3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.6
Fixed in
  • 18.6
PostgreSQLAffected
  • >=17 <17.11
Fixed in
  • 17.11
PostgreSQLAffected
  • >=16 <16.15
Fixed in
  • 16.15
PostgreSQLAffected
  • >=15 <15.19
Fixed in
  • 15.19
PostgreSQLAffected
  • <14.24
Fixed in
  • 14.24
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <18.5
  • <17.11
  • <16.15
  • <15.19
  • <14.24
Fixed in
  • 18.5
  • 17.11
  • 16.15
  • 15.19
  • 14.24

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Type confusion in PostgreSQL module "refint" allows an object creator to execute arbitrary code as the operating system user running the database. The fix for this emerged as a non-security bug report, and the fix appear in the git repository with subject "refint: Remove plan cache.", without a CVE number. Versions before PostgreSQL 18.5, 17.11, 16.15, 15.19, and 14.24 are affected.

References

Community reviews

Loading reviews…