Skip to main content
CVE-2024-52316VulnerabilityPublished Updated

Red Hat Security Advisory: tomcat security update

Affects Red HatSource GCVE Database

0
Authoritative record:CVE-2024-52316· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 10.1.16-1ubuntu0.1~esm3 as a priority.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
6.2% chance of exploitation in 30 days – higher than 93% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.1.16-1ubuntu0.1~esm3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade tomcat10 to 10.1.16-1ubuntu0.1~esm3.

Affected software

ProductAffectedFixed in
Ubuntu:Pro:16.04:LTStomcat8pkg:deb/ubuntu/tomcat8@8.0.32-1ubuntu1.13+esm2?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • =8.0.26-1
  • =8.0.28-1
  • =8.0.30-1
  • =8.0.32-1
  • =8.0.32-1ubuntu1
  • =8.0.32-1ubuntu1.1
  • =8.0.32-1ubuntu1.2
  • =8.0.32-1ubuntu1.3
  • =8.0.32-1ubuntu1.4
  • =8.0.32-1ubuntu1.5
  • =8.0.32-1ubuntu1.6
  • =8.0.32-1ubuntu1.7
  • =8.0.32-1ubuntu1.8
  • =8.0.32-1ubuntu1.9
  • =8.0.32-1ubuntu1.10
  • =8.0.32-1ubuntu1.11
  • =8.0.32-1ubuntu1.13
  • =8.0.32-1ubuntu1.13+esm1
  • =8.0.32-1ubuntu1.13+esm2
Fixed in–
Ubuntu:Pro:18.04:LTStomcat8pkg:deb/ubuntu/tomcat8@8.5.39-1ubuntu1~18.04.3+esm6?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =8.5.21-1ubuntu1
  • =8.5.29-1
  • =8.5.30-1
  • =8.5.30-1ubuntu1
  • =8.5.30-1ubuntu1.2
  • =8.5.30-1ubuntu1.3
  • =8.5.30-1ubuntu1.4
  • =8.5.39-1ubuntu1~18.04.1
  • =8.5.39-1ubuntu1~18.04.2
  • =8.5.39-1ubuntu1~18.04.3
  • =8.5.39-1ubuntu1~18.04.3+esm1
  • =8.5.39-1ubuntu1~18.04.3+esm2
  • =8.5.39-1ubuntu1~18.04.3+esm3
  • =8.5.39-1ubuntu1~18.04.3+esm4
  • =8.5.39-1ubuntu1~18.04.3+esm5
  • =8.5.39-1ubuntu1~18.04.3+esm6
Fixed in–
Ubuntu:Pro:18.04:LTStomcat9pkg:deb/ubuntu/tomcat9@9.0.16-3ubuntu0.18.04.2+esm8?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =9.0.16-3~18.04.1
  • =9.0.16-3ubuntu0.18.04.1
  • =9.0.16-3ubuntu0.18.04.2
  • =9.0.16-3ubuntu0.18.04.2+esm1
  • =9.0.16-3ubuntu0.18.04.2+esm2
  • =9.0.16-3ubuntu0.18.04.2+esm3
  • =9.0.16-3ubuntu0.18.04.2+esm4
  • =9.0.16-3ubuntu0.18.04.2+esm5
  • =9.0.16-3ubuntu0.18.04.2+esm6
  • =9.0.16-3ubuntu0.18.04.2+esm7
  • =9.0.16-3ubuntu0.18.04.2+esm8
Fixed in–
Ubuntu:Pro:20.04:LTStomcat9pkg:deb/ubuntu/tomcat9@9.0.31-1ubuntu0.9+esm3?arch=source&distro=esm-apps/focalOther threatsAffected
  • =9.0.24-1
  • =9.0.27-1
  • =9.0.31-1
  • =9.0.31-1ubuntu0.1
  • =9.0.31-1ubuntu0.2
  • =9.0.31-1ubuntu0.3
  • =9.0.31-1ubuntu0.4
  • =9.0.31-1ubuntu0.5
  • =9.0.31-1ubuntu0.6
  • =9.0.31-1ubuntu0.7
  • =9.0.31-1ubuntu0.8
  • =9.0.31-1ubuntu0.9
  • =9.0.31-1ubuntu0.9+esm1
  • =9.0.31-1ubuntu0.9+esm2
  • =9.0.31-1ubuntu0.9+esm3
Fixed in–
Ubuntu:Pro:22.04:LTStomcat9pkg:deb/ubuntu/tomcat9@9.0.58-1ubuntu0.2+esm4?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =9.0.43-3
  • =9.0.54-1
  • =9.0.55-1
  • =9.0.58-1
  • =9.0.58-1ubuntu0.1
  • =9.0.58-1ubuntu0.1+esm1
  • =9.0.58-1ubuntu0.1+esm2
  • =9.0.58-1ubuntu0.1+esm3
  • =9.0.58-1ubuntu0.1+esm4
  • =9.0.58-1ubuntu0.2
  • =9.0.58-1ubuntu0.2+esm1
  • =9.0.58-1ubuntu0.2+esm2
  • =9.0.58-1ubuntu0.2+esm3
  • =9.0.58-1ubuntu0.2+esm4
Fixed in–
Ubuntu:Pro:24.04:LTStomcat10pkg:deb/ubuntu/tomcat10@10.1.16-1ubuntu0.1~esm3?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <10.1.16-1ubuntu0.1~esm3
  • =10.1.10-1
  • =10.1.14-1
  • =10.1.15-1
  • =10.1.16-1
  • =10.1.16-1ubuntu0.1~esm1
  • =10.1.16-1ubuntu0.1~esm2
Fixed in
  • 10.1.16-1ubuntu0.1~esm3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Red Hat and SUSE have released updated packages addressing CVE-2024-52316 and other issues. Users should upgrade to the fixed versions as listed in the advisory. No vendor advisory states that no action is required; therefore, applying the official update is the recommended mitigation.

Description

A critical authentication bypass vulnerability (CVE-2024-52316) affecting Apache Tomcat 10.1.33 and related versions has been addressed in a security update provided by Red Hat and SUSE. The vulnerability involves improper handling of Jakarta Authentication failures that could lead to incorrect HTTP status codes. The update also includes fixes for WebDAV compliance, cache handling, logging, and concurrency issues. Patches are available for multiple affected versions across Red Hat Enterprise Linux and Ubuntu distributions.

References

Community reviews

Loading reviews…