Skip to main content
VulnerabilityPublished Updated

CVE-2025-31651: Tomcat8 · Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat

Affects tomcat8Source GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 10.1.16-1ubuntu0.1~esm3 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
4.1% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.1.16-1ubuntu0.1~esm3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu tomcat10 package to 10.1.16-1ubuntu0.1~esm3.

Affected software

ProductAffectedFixed in
Ubuntu Pro 24.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <10.1.16-1ubuntu0.1~esm3
Fixed in
  • 10.1.16-1ubuntu0.1~esm3
Ubuntu Pro 22.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 9.0.43-3 – 9.0.58-1ubuntu0.2+esm4
14 affected builds
Fixed in–
Ubuntu Pro 20.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/focalOther threatsAffected
  • 9.0.24-1 – 9.0.31-1ubuntu0.9+esm3
15 affected builds
Fixed in–
Ubuntu Pro 18.04 LTStomcat8pkg:deb/ubuntu/tomcat8?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 8.5.21-1ubuntu1 – 8.5.39-1ubuntu1~18.04.3+esm6
16 affected builds
Fixed in–
Ubuntu Pro 18.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 9.0.16-3~18.04.1 – 9.0.16-3ubuntu0.18.04.2+esm8
11 affected builds
Fixed in–
Ubuntu Pro 16.04 LTStomcat8pkg:deb/ubuntu/tomcat8?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 8.0.26-1 – 8.0.32-1ubuntu1.13+esm2
19 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. For a subset of unlikely rewrite rule configurations, it was possible for a specially crafted request to bypass some rewrite rules. If those rewrite rules effectively enforced security constraints, those constraints could be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.5, from 10.1.0-M1 through 10.1.39, from 9.0.0.M1 through 9.0.102. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version [FIXED_VERSION], which fixes the issue.

References

Community reviews

Loading reviews…