Skip to main content
VulnerabilityPublished Updated

CVE-2025-40335: Linux kernel · drm/amdgpu: validate userq input args

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · fixed in 6.17.0-1007.7~24.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1007.7~24.04.1, 6.17.0-1008.8~24.04.1, 6.17.0-1008.8 +6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-14.14?arch=source&distro=questingOther threatsAffected
  • <6.17.0-14.14
Fixed in
  • 6.17.0-14.14
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1008.8?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1008.8
Fixed in
  • 6.17.0-1008.8
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1007.7?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available and should be applied. The vendor advisory from Ubuntu confirms that the issue is resolved in updated Linux kernel packages. Users should upgrade to the fixed kernel versions as specified in the advisory to mitigate this vulnerability.

Description

A vulnerability in the Linux kernel's drm/amdgpu subsystem related to validation of user queue (userq) input arguments has been resolved. The fix improves validation of userq input arguments and rejects invalid userq requests at the IOCTL interface. This vulnerability is addressed in multiple Linux kernel versions as part of a broader security update that fixes several issues across many subsystems.

References

Community reviews

Loading reviews…