CVE-2025-40336: Linux kernel · drm/gpusvm: fix hmm_pfn_to_map_order() usage
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.8 High · fixed in 6.17.0-1007.7~24.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.17.0-1007.7~24.04.1, 6.17.0-1008.8~24.04.1, 6.17.0-1008.8 +6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-14.14?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1008.8?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. The vulnerability is fixed in Linux kernel versions 6.17.0-1007.7~24.04.1, 6.17.0-1008.8~24.04.1, 6.17.0-1008.8, and 6.17.0-1011.11 and later. Users and administrators should update to these or later kernel versions as provided by their Linux distribution. No additional mitigations are specified by the vendor advisory.
Description
A vulnerability in the Linux kernel's drm/gpusvm subsystem related to incorrect handling of huge page ranges in the hmm_pfn_to_map_order() function has been resolved. The flaw could lead to mapping memory outside the intended range, potentially causing serious memory corruption. This issue has been fixed in Linux kernel versions 6.17.0-1007.7~24.04.1 and later. The vulnerability has a CVSS score of 8.8, indicating high severity. Multiple Linux kernel subsystems have received security updates in the same advisory. No known exploits are reported in the wild.
References
- ubuntu.com/security/CVE-2025-40336 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-40336 (opens in a new tab)
- git.kernel.org/linus/c50729c68aaf93611c855752b00e49ce1fdd1558 (opens in a new tab)
- git.kernel.org/stable/c/08e9fd78ba1b9e95141181c69cc51795c9888157 (opens in a new tab)
- git.kernel.org/stable/c/c50729c68aaf93611c855752b00e49ce1fdd1558 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8030-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8048-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-3 (opens in a new tab)