CVE-2025-40362: Linux kernel · ceph: fix multifs mds auth caps issue
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.8 High · fixed in 6.17.0-1007.7~24.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 11:07 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.17.0-1007.7~24.04.1, 6.17.0-1008.8~24.04.1, 6.17.0-1008.8 +6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-14.14?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1008.8?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1007.7?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available and should be applied by upgrading the Linux kernel to versions 6.17.0-1007.7~24.04.1 or later. The vendor advisory from Ubuntu confirms that this and other Linux kernel vulnerabilities have been addressed in security updates. Users should apply these updates promptly to mitigate the risk.
Description
A vulnerability in the Linux kernel's Ceph distributed file system allowed improper validation of multi-filesystem (multifs) MDS authorization capabilities. This flaw caused the authorization caps of one filesystem to be incorrectly applied to another, enabling users to gain unauthorized write permissions on filesystems where they should have read-only access. The issue has been fixed in Linux kernel versions 6.17.0-1007.7~24.04.1 and later.
References
- ubuntu.com/security/CVE-2025-40362 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-40362 (opens in a new tab)
- git.kernel.org/linus/22c73d52a6d05c5a2053385c0d6cd9984732799d (opens in a new tab)
- git.kernel.org/stable/c/07640d34a781bb2e39020a39137073c03c4aa932 (opens in a new tab)
- git.kernel.org/stable/c/22c73d52a6d05c5a2053385c0d6cd9984732799d (opens in a new tab)
- git.kernel.org/stable/c/ca3da8b27ab9a0923ad477447cfb8fc7f4b4c523 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8030-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8048-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8029-3 (opens in a new tab)