Skip to main content
VulnerabilityPublished Updated

CVE-2025-46701: Apache Tomcat · Security constraint bypass for CGI scripts

Affects tomcatSource GCVE Database

0
Authoritative record:CVE-2025-46701· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 10.1.16-1ubuntu0.1~esm3 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
3.1% chance of exploitation in 30 days – higher than 87% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.1.16-1ubuntu0.1~esm3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu tomcat10 package to 10.1.16-1ubuntu0.1~esm3.

Affected software

ProductAffectedFixed in
Ubuntu:Pro:14.04:LTStomcat6pkg:deb/ubuntu/tomcat6@6.0.39-1ubuntu0.1+esm3?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • =6.0.37-1
  • =6.0.39-1
  • =6.0.39-1ubuntu0.1
  • =6.0.39-1ubuntu0.1+esm1
  • =6.0.39-1ubuntu0.1+esm2
  • =6.0.39-1ubuntu0.1+esm3
Fixed in–
Ubuntu:Pro:14.04:LTStomcat7pkg:deb/ubuntu/tomcat7@7.0.52-1ubuntu0.16+esm2?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • =7.0.42-1
  • =7.0.47-1
  • =7.0.50-1
  • =7.0.52-1
  • =7.0.52-1ubuntu0.1
  • =7.0.52-1ubuntu0.3
  • =7.0.52-1ubuntu0.6
  • =7.0.52-1ubuntu0.7
  • =7.0.52-1ubuntu0.8
  • =7.0.52-1ubuntu0.9
  • =7.0.52-1ubuntu0.10
  • =7.0.52-1ubuntu0.11
  • =7.0.52-1ubuntu0.13
  • =7.0.52-1ubuntu0.14
  • =7.0.52-1ubuntu0.15
  • =7.0.52-1ubuntu0.16
  • =7.0.52-1ubuntu0.16+esm1
  • =7.0.52-1ubuntu0.16+esm2
Fixed in–
Ubuntu:Pro:16.04:LTStomcat8pkg:deb/ubuntu/tomcat8@8.0.32-1ubuntu1.13+esm2?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • =8.0.26-1
  • =8.0.28-1
  • =8.0.30-1
  • =8.0.32-1
  • =8.0.32-1ubuntu1
  • =8.0.32-1ubuntu1.1
  • =8.0.32-1ubuntu1.2
  • =8.0.32-1ubuntu1.3
  • =8.0.32-1ubuntu1.4
  • =8.0.32-1ubuntu1.5
  • =8.0.32-1ubuntu1.6
  • =8.0.32-1ubuntu1.7
  • =8.0.32-1ubuntu1.8
  • =8.0.32-1ubuntu1.9
  • =8.0.32-1ubuntu1.10
  • =8.0.32-1ubuntu1.11
  • =8.0.32-1ubuntu1.13
  • =8.0.32-1ubuntu1.13+esm1
  • =8.0.32-1ubuntu1.13+esm2
Fixed in–
Ubuntu:Pro:16.04:LTStomcat7pkg:deb/ubuntu/tomcat7@7.0.68-1ubuntu0.4+esm4?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • =7.0.64-1
  • =7.0.68-1
  • =7.0.68-1ubuntu0.1
  • =7.0.68-1ubuntu0.3
  • =7.0.68-1ubuntu0.4
  • =7.0.68-1ubuntu0.4+esm1
  • =7.0.68-1ubuntu0.4+esm2
  • =7.0.68-1ubuntu0.4+esm3
  • =7.0.68-1ubuntu0.4+esm4
Fixed in–
Ubuntu:Pro:18.04:LTStomcat8pkg:deb/ubuntu/tomcat8@8.5.39-1ubuntu1~18.04.3+esm6?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =8.5.21-1ubuntu1
  • =8.5.29-1
  • =8.5.30-1
  • =8.5.30-1ubuntu1
  • =8.5.30-1ubuntu1.2
  • =8.5.30-1ubuntu1.3
  • =8.5.30-1ubuntu1.4
  • =8.5.39-1ubuntu1~18.04.1
  • =8.5.39-1ubuntu1~18.04.2
  • =8.5.39-1ubuntu1~18.04.3
  • =8.5.39-1ubuntu1~18.04.3+esm1
  • =8.5.39-1ubuntu1~18.04.3+esm2
  • =8.5.39-1ubuntu1~18.04.3+esm3
  • =8.5.39-1ubuntu1~18.04.3+esm4
  • =8.5.39-1ubuntu1~18.04.3+esm5
  • =8.5.39-1ubuntu1~18.04.3+esm6
Fixed in–
Ubuntu:Pro:18.04:LTStomcat9pkg:deb/ubuntu/tomcat9@9.0.16-3ubuntu0.18.04.2+esm8?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =9.0.16-3~18.04.1
  • =9.0.16-3ubuntu0.18.04.1
  • =9.0.16-3ubuntu0.18.04.2
  • =9.0.16-3ubuntu0.18.04.2+esm1
  • =9.0.16-3ubuntu0.18.04.2+esm2
  • =9.0.16-3ubuntu0.18.04.2+esm3
  • =9.0.16-3ubuntu0.18.04.2+esm4
  • =9.0.16-3ubuntu0.18.04.2+esm5
  • =9.0.16-3ubuntu0.18.04.2+esm6
  • =9.0.16-3ubuntu0.18.04.2+esm7
  • =9.0.16-3ubuntu0.18.04.2+esm8
Fixed in–
Ubuntu:Pro:20.04:LTStomcat9pkg:deb/ubuntu/tomcat9@9.0.31-1ubuntu0.9+esm3?arch=source&distro=esm-apps/focalOther threatsAffected
  • =9.0.24-1
  • =9.0.27-1
  • =9.0.31-1
  • =9.0.31-1ubuntu0.1
  • =9.0.31-1ubuntu0.2
  • =9.0.31-1ubuntu0.3
  • =9.0.31-1ubuntu0.4
  • =9.0.31-1ubuntu0.5
  • =9.0.31-1ubuntu0.6
  • =9.0.31-1ubuntu0.7
  • =9.0.31-1ubuntu0.8
  • =9.0.31-1ubuntu0.9
  • =9.0.31-1ubuntu0.9+esm1
  • =9.0.31-1ubuntu0.9+esm2
  • =9.0.31-1ubuntu0.9+esm3
Fixed in–
Ubuntu:Pro:22.04:LTStomcat9pkg:deb/ubuntu/tomcat9@9.0.58-1ubuntu0.2+esm4?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =9.0.43-3
  • =9.0.54-1
  • =9.0.55-1
  • =9.0.58-1
  • =9.0.58-1ubuntu0.1
  • =9.0.58-1ubuntu0.1+esm1
  • =9.0.58-1ubuntu0.1+esm2
  • =9.0.58-1ubuntu0.1+esm3
  • =9.0.58-1ubuntu0.1+esm4
  • =9.0.58-1ubuntu0.2
  • =9.0.58-1ubuntu0.2+esm1
  • =9.0.58-1ubuntu0.2+esm2
  • =9.0.58-1ubuntu0.2+esm3
  • =9.0.58-1ubuntu0.2+esm4
Fixed in–
Ubuntu:Pro:24.04:LTStomcat10pkg:deb/ubuntu/tomcat10@10.1.16-1ubuntu0.1~esm3?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <10.1.16-1ubuntu0.1~esm3
  • =10.1.10-1
  • =10.1.14-1
  • =10.1.15-1
  • =10.1.16-1
  • =10.1.16-1ubuntu0.1~esm1
  • =10.1.16-1ubuntu0.1~esm2
Fixed in
  • 10.1.16-1ubuntu0.1~esm3
Ubuntu:25.10tomcat11pkg:deb/ubuntu/tomcat11@11.0.6-1?arch=source&distro=questingOther threatsAffected
  • =11.0.6-1
Fixed in–
Ubuntu:26.04:LTStomcat11pkg:deb/ubuntu/tomcat11@11.0.22-2ubuntu2~26.04.1?arch=source&distro=resoluteOther threatsAffected
  • =11.0.6-1
  • =11.0.11-1
  • =11.0.15-1
  • =11.0.18-1
  • =11.0.18-1ubuntu0.1~esm1
  • =11.0.22-2ubuntu2~26.04.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade Apache Tomcat to versions 11.0.7, 10.1.41, or 9.0.105 or later. For Ubuntu users, applying standard system updates or using Ubuntu Pro Extended Security Maintenance (ESM) for affected LTS releases will address the vulnerability. No additional mitigation steps are indicated beyond applying these updates.

Description

CVE-2025-46701 is a security vulnerability in Apache Tomcat affecting multiple versions from 6.0.37 through 11.0.6. It involves improper handling of case sensitivity in the CGI servlet, allowing bypass of security constraints applied to the pathInfo component of a URI. This flaw could enable an attacker to bypass authentication mechanisms. The issue has been fixed in Apache Tomcat versions 11.0.7, 10.1.41, and 9.0.105. Users are advised to upgrade to these or later versions to mitigate the risk.

References

Community reviews

Loading reviews…