CVE-2025-68283: Linux kernel · libceph: replace BUG_ON with bounds check for map->max_osd
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 6.8.0-1050.53~22.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 11:42 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1050.53~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1052.55~22.04.1 +40
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-19.19?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1009.9?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1010.10?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1009.9?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1009.9?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available and should be applied to affected Linux kernel versions. The vulnerability is resolved by replacing the BUG_ON assertion with proper boundary checks in libceph. Users should update their Linux kernel to versions 6.8.0-1049.49 or later as provided by their distribution. No additional mitigation is required beyond applying the official fix.
Description
A vulnerability in the Linux kernel's libceph component was resolved by replacing a BUG_ON assertion with proper boundary checks for map->max_osd. The issue involved OSD indexes derived from untrusted network packets lacking adequate validation, which could lead to a denial of service. The vulnerability has a CVSS score of 7.5 and is classified as medium severity. Multiple Linux kernel versions prior to 6.8.0-1049.49 through 6.8.0-1052.55~22.04.1 are affected. An official patch is available to address this issue.
References
- ubuntu.com/security/CVE-2025-68283 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-68283 (opens in a new tab)
- git.kernel.org/linus/ec3797f043756a94ea2d0f106022e14ac4946c02 (opens in a new tab)
- git.kernel.org/stable/c/57f5fbae9f1024aba17ff75e00433324115c548a (opens in a new tab)
- git.kernel.org/stable/c/b4368b7f97014e1015445d61abd0b27c4c6e8424 (opens in a new tab)
- git.kernel.org/stable/c/becc488a4d864db338ebd4e313aa3c77da24b604 (opens in a new tab)
- git.kernel.org/stable/c/e67e3be690f5f7e3b031cf29e8d91e6d02a8e30d (opens in a new tab)
- git.kernel.org/stable/c/ec3797f043756a94ea2d0f106022e14ac4946c02 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8125-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8126-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8094-5 (opens in a new tab)