CVE-2025-68777: Linux kernel · Input: ti_am335x_tsc – fix off-by-one error in wire_order validation
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 5.15.0-1103.110~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +70
Exploitation evidence
Disclosed: evidence found.
CVE published 13 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-22.22?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1012.12?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1013.13?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1012.12?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1011.11?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released by Ubuntu as part of security update USN-8096-1. Users should update their Linux kernel to the fixed versions listed in the advisory to remediate this vulnerability. The affected versions are prior to 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1, 5.15.0-173.183~20.04.1, and 5.15.0-1097.100~20.04.1. No additional mitigations are indicated by the vendor advisory.
Description
An off-by-one error in the Linux kernel's ti_am335x_tsc input driver allowed out-of-bounds access due to improper validation of the wire_order array index. The validation check permitted wire_order[i] to equal the size of the config_pins array, which has 4 elements, causing an out-of-bounds access when indexing config_pins. This vulnerability has been fixed by changing the validation condition to prevent wire_order[i] from being equal to or greater than the array size. The issue affects certain Linux kernel versions prior to specific 5.15.x updates.
References
- ubuntu.com/security/CVE-2025-68777 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-68777 (opens in a new tab)
- git.kernel.org/linus/248d3a73a0167dce15ba100477c3e778c4787178 (opens in a new tab)
- git.kernel.org/stable/c/08c0b561823a7026364efb38ed7f4a3af48ccfcd (opens in a new tab)
- git.kernel.org/stable/c/248d3a73a0167dce15ba100477c3e778c4787178 (opens in a new tab)
- git.kernel.org/stable/c/40e3042de43ffa0017a8460ff9b4cad7b8c7cb96 (opens in a new tab)
- git.kernel.org/stable/c/84e4d3543168912549271b34261f5e0f94952d6e (opens in a new tab)
- git.kernel.org/stable/c/bf95ec55805828c4f2b5241fb6b0c12388548570 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8116-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8141-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8163-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8163-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8179-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-2 (opens in a new tab)