CVE-2025-71125: Linux kernel · tracing: Do not register unsupported perf events
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 5.15.0-1103.110~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +70
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-22.22?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1012.12?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1013.13?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1012.12?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1011.11?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied to affected Linux kernel versions to prevent the kernel warnings and potential denial of service. The fix changes the code to return an error instead of registering unsupported synthetic perf events. Users should update to the fixed kernel versions as indicated in the vendor advisory. No additional mitigation is required as the issue is resolved by the official patch.
Description
A vulnerability in the Linux kernel tracing subsystem caused unsupported synthetic perf events to be registered with a NULL function pointer, triggering kernel warnings and potential instability. The issue arises because synthetic events lack a function to register perf events, leading to a kernel warning and possible denial of service. The fix changes the code to return an error code instead of registering unsupported events, preventing the warning and perf errors. This vulnerability affects certain Linux kernel versions prior to specific 5.15.x updates and has a medium severity rating.
References
- ubuntu.com/security/CVE-2025-71125 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-71125 (opens in a new tab)
- git.kernel.org/stable/c/3437c775bf209c674ad66304213b6b3c3b1b3f69 (opens in a new tab)
- git.kernel.org/stable/c/65b1971147ec12f0b1cee0811c859a3d7d9b04ce (opens in a new tab)
- git.kernel.org/stable/c/6df47e5bb9b62d72f186f826ab643ea1856877c7 (opens in a new tab)
- git.kernel.org/stable/c/ef7f38df890f5dcd2ae62f8dbde191d72f3bebae (opens in a new tab)
- git.kernel.org/stable/c/f7305697b60d79bc69c0a6e280fc931b4e8862dd (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8116-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8141-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8163-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8163-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8179-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8183-1 (opens in a new tab)