Skip to main content
VulnerabilityPublished Updated

CVE-2026-44512: Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability

Affects onnxSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.5 Medium · fixed in 1.22.0 : update onnx when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.22.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10onnxpkg:deb/ubuntu/onnx?arch=source&distro=stonkingOther threatsAffected
  • =1.20.0-1
  • =1.20.0-6
Fixed in–
Ubuntu 26.04 LTSonnxpkg:deb/ubuntu/onnx?arch=source&distro=resoluteOther threatsAffected
  • =1.17.0-3build1
  • =1.20.0-1
Fixed in–
Ubuntu 25.10onnxpkg:deb/ubuntu/onnx?arch=source&distro=questingOther threatsAffected
  • =1.17.0-3build1
Fixed in–
Ubuntu Pro 24.04 LTSonnxpkg:deb/ubuntu/onnx?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 1.13.1-3 – 1.14.1-2.1ubuntu0.1~esm1
7 affected builds
Fixed in–
Ubuntu 22.04 LTSonnxpkg:deb/ubuntu/onnx?arch=source&distro=jammyOther threatsAffected
  • 1.7.0+dfsg-3build1 – 1.7.0+dfsg-3ubuntu2
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to ONNX version 1.22.0 or later, where this vulnerability is fixed. No other mitigation is indicated or required.

Description

A denial of service vulnerability exists in the Open Neural Network Exchange (ONNX) library versions from 1.9.0 up to but not including 1.22.0. The issue occurs due to a null pointer dereference in the Upsample node processing when onnx.version_converter.convert_version() handles an untrusted model containing an Upsample node with zero inputs, causing the application to crash. This vulnerability is fixed in version 1.22.0.

References

Community reviews

Loading reviews…