Skip to main content
VulnerabilityPublished Updated

CVE-2026-54919: In affected Mbed TLS backend versions from 0.31.0 through 0.46.1 and wolfSSL backend versions from 0.33.0 through 0.46.1, when cpp-httplib is built

Affects cpp-httplibSource GCVE Database

0
Compare
Authoritative record:CVE-2026-54919· High 7.4

Not known to be exploited · CVSS 7.4 High · fixed in 0.47.0 : patch cpp-httplib soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.47.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10cpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=stonkingOther threatsAffected
  • =0.26.0+ds-2ubuntu3
  • =0.26.0+ds-2ubuntu4
Fixed in–
Ubuntu Pro 26.04 LTScpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 0.18.7-1 – 0.26.0+ds-2ubuntu3+esm1
4 affected builds
Fixed in–
Ubuntu Pro 24.04 LTScpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 0.13.1+ds-1ubuntu1 – 0.14.3+ds-1.1ubuntu0.1~esm2
7 affected builds
Fixed in–
Ubuntu Pro 22.04 LTScpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 0.9.9+ds-1 – 0.10.3+ds-1ubuntu0.1~esm2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade cpp-httplib to version 0.47.0 or later, where the SSL certificate chain validation issue is fixed. No other mitigation is specified or required.

Description

cpp-httplib versions built with Mbed TLS or wolfSSL backend from 0.31.0 through 0.46.1 improperly skip SSL certificate chain validation when connecting to IP-literal hosts with server certificate verification enabled. This vulnerability affects SSLClient and Client in HTTPS mode and WebSocketClient on the Mbed TLS backend, allowing a man-in-the-middle attacker to present a crafted certificate and intercept or modify traffic. The issue is fixed in version 0.47.0.

References

Community reviews

Loading reviews…