Skip to main content
CVE-2026-56000VulnerabilityPublished Updated

Local attackers with a X connection able to provide GLX commit to the X server xorg-server before 21.2.24 and xwayland

Affects xorg-serverSource GCVE Database

0
Compare
Authoritative record:CVE-2026-56000· Critical 9.0

Not known to be exploited · CVSS 9.0 Critical.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10xorg-serverpkg:deb/ubuntu/xorg-server?arch=source&distro=stonkingOther threatsAffected
  • =2:21.1.22-1ubuntu1
  • =2:21.1.22-1ubuntu4
  • =2:21.1.24-1ubuntu1
Fixed in–
Ubuntu 26.10xwaylandpkg:deb/ubuntu/xwayland?arch=source&distro=stonkingOther threatsAffected
  • 2:24.1.10-1 – 2:24.1.14-1
4 affected builds
Fixed in–
Ubuntu 26.04 LTSxorg-serverpkg:deb/ubuntu/xorg-server?arch=source&distro=resoluteOther threatsAffected
  • 2:21.1.18-1ubuntu1 – 2:21.1.22-1ubuntu1.3
5 affected builds
Fixed in–
Ubuntu 26.04 LTSxwaylandpkg:deb/ubuntu/xwayland?arch=source&distro=resoluteOther threatsAffected
  • 2:24.1.6-1ubuntu1 – 2:24.1.10-1
4 affected builds
Fixed in–
Ubuntu 25.10xorg-serverpkg:deb/ubuntu/xorg-server?arch=source&distro=questingOther threatsAffected
  • =2:21.1.16-1ubuntu1
  • =2:21.1.18-1ubuntu1
  • =2:21.1.18-1ubuntu1.1
Fixed in–
Ubuntu 25.10xwaylandpkg:deb/ubuntu/xwayland?arch=source&distro=questingOther threatsAffected
  • =2:24.1.6-1
  • =2:24.1.6-1ubuntu1
  • =2:24.1.6-1ubuntu1.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability affects xorg-server versions before 21.2.24 and xwayland before 24.1.13. Users should upgrade to xorg-server version 21.2.24 or later and xwayland version 24.1.13 or later once available.

Description

A heap use-after-free vulnerability exists in xorg-server versions before 21.2.24 and xwayland before 24.1.13. Local attackers with an X connection can exploit this by providing a GLX commit to the X server, causing CommonMakeCurrent() to reference potentially reallocated memory. This vulnerability can lead to high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…