CVE-2026-57214: Rabbitmq server · RabbitMQ is a messaging and streaming broker
Affects rabbitmq-serverSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 4.2.5 : patch rabbitmq-server soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server@3.8.3-0ubuntu0.3?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade RabbitMQ to version 4.2.5 or later, where this vulnerability is fixed. No other specific mitigations are indicated. Users should apply the official fix to prevent exploitation.
Description
RabbitMQ versions prior to 4.2.5 contain a vulnerability in the management UI where the x-internal-purpose queue or exchange argument is improperly escaped in an HTML title attribute. This flaw allows a user with permission to declare a queue or exchange to execute JavaScript in another user's browser. The vulnerability is fixed in RabbitMQ version 4.2.5.
References
- ubuntu.com/security/CVE-2026-57214 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-57214 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/b0027b6c1ae5b869d876e211efe6189ffd92b5c2 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/b267a290dd89e42c6e0256f46fc273a8adb7f3ec (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/15606 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/15608 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.5 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-6jfq-prw2-7rwp (opens in a new tab)