CVE-2026-57216: Rabbitmq server · RabbitMQ is a messaging and streaming broker
Affects rabbitmq-serverSource GCVE Database
Not known to be exploited · CVSS 6.8 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server@3.8.3-0ubuntu0.3?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade RabbitMQ to version 3.13.15, 4.0.20, 4.1.11, or 4.2.6 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated. Patch status is confirmed by the vendor advisory.
Description
RabbitMQ versions prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6 contain a vulnerability in the AMQP 0-9-1, AMQP 1.0, and Stream Protocol authentication mechanisms. This flaw allows a loopback-restricted user such as 'guest' to connect remotely if traffic is accepted through a trusted PROXY-protocol path and the backend listener is bound to loopback. The issue is due to the loopback check using the listener-side socket address instead of the actual client source address. Fixed versions include 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
References
- ubuntu.com/security/CVE-2026-57216 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-57216 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/7273c9eb6920abcde17b892dbe97ccaf906ead47 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/9f8c39fcf0acbc43080ee7017a62a02832114112 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/15936 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/15940 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-36m6-588r-vqcw (opens in a new tab)