CVE-2026-57218: Rabbitmq server · RabbitMQ is a messaging and streaming broker
Affects rabbitmq-serverSource GCVE Database
Not known to be exploited · CVSS 4.9 Medium · fixed in 4.2.6 : update rabbitmq-server when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server@3.8.3-0ubuntu0.3?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade RabbitMQ to version 4.2.6 or later, where this issue is fixed. No other mitigation is indicated by the vendor advisory.
Description
RabbitMQ versions prior to 4.2.6 contain a vulnerability in the AMQP 0-9-1 protocol where consumers continue to receive messages even after their OAuth token expires or their scopes are reduced. This occurs because consumers are not canceled or reauthorized when the channel user state changes. The issue is fixed in RabbitMQ version 4.2.6.
References
- ubuntu.com/security/CVE-2026-57218 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-57218 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/501ad947cd6bbcc9486fe96e0d073992bfe52cc4 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/db20d6c0fcf3056030f244b5adab0d45c0db0c9e (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/16092 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/16097 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-wmrr-4h5v-5ch7 (opens in a new tab)