Skip to main content
VulnerabilityPublished Updated

CVE-2026-57220: Rabbitmq server · RabbitMQ is a messaging and streaming broker

Affects rabbitmq-serverSource GCVE Database

0
Compare
Authoritative record:CVE-2026-57220· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 4.2.6 : patch rabbitmq-server soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10rabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=stonkingOther threatsAffected
  • =4.0.5-10ubuntu5
  • =4.3.2-4ubuntu2
  • =4.3.2-4ubuntu3
Fixed in–
Ubuntu 26.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=resoluteOther threatsAffected
  • 4.0.5-8ubuntu2 – 4.0.5-10ubuntu5.2
8 affected builds
Fixed in–
Ubuntu 24.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=nobleOther threatsAffected
  • 3.12.1-1 – 3.12.1-1ubuntu1.7
6 affected builds
Fixed in–
Ubuntu 22.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=jammyOther threatsAffected
  • 3.8.9-3ubuntu1 – 3.9.27-0ubuntu0.6
13 affected builds
Fixed in–
Ubuntu 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server@3.8.3-0ubuntu0.3?arch=source&distro=focalOther threatsAffected
  • 3.7.8-4ubuntu2 – 3.8.3-0ubuntu0.3
11 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/focalOther threatsAffected
  • 3.7.8-4ubuntu2 – 3.8.3-0ubuntu0.3+esm2
13 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in RabbitMQ version 4.2.6. Users should upgrade to version 4.2.6 or later to remediate this vulnerability.

Description

RabbitMQ versions prior to 4.2.6 contain a vulnerability in the stream listener where the configured stream frame-size limit is not enforced during frame assembly in authentication and before Tune negotiation. This flaw allows an unauthenticated remote client to declare oversized frame lengths, potentially consuming broker memory. The issue is fixed in RabbitMQ version 4.2.6.

References

Community reviews

Loading reviews…