CVE-2026-59948: Composer is a dependency Manager for the PHP language
Affects composerSource GCVE Database
Not known to be exploited · CVSS 7.0 High · fixed in 2.2.29 : patch composer soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.29
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10composerpkg:deb/ubuntu/composer?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTScomposerpkg:deb/ubuntu/composer?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10composerpkg:deb/ubuntu/composer?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTScomposerpkg:deb/ubuntu/composer?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTScomposerpkg:deb/ubuntu/composer?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTScomposerpkg:deb/ubuntu/composer?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Composer to version 2.2.29 or later, or 2.10.2 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.
Description
Composer, a PHP dependency manager, has a vulnerability in versions prior to 2.2.29 and 2.10.2 that allows a malicious package from an untrusted repository to write files outside intended directories during install or update. This is due to improper validation of package names before dependency resolution. The issue is fixed in versions 2.2.29 and 2.10.2.