Skip to main content
VulnerabilityPublished

CVE-2026-109125: unbound security update

Affects unboundSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-109125· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.17.1-25.oe2403sp1 when convenient.

Data as of 4 Nov 2026, 16:47 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (NLnet Labs)CVSS 3.15.3
Patch
Available – fixed in 1.17.1-25.oe2403sp1
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade unbound to 1.17.1-25.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1unboundpkg:rpm/openEuler/unbound&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <1.17.1-25.oe2403sp1
Fixed in
  • 1.17.1-25.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in NLnet Labs Unbound version 1.17.1-25.oe2403sp1. Users should upgrade to this fixed version to remediate the issues. No additional mitigations are indicated or required if the update is applied. For configurations using 'unwanted-reply-threshold', consider reverting to default settings to reduce exposure until patched.

Description

Multiple security vulnerabilities affect NLnet Labs Unbound up to and including version 1.26.1. These include a cache-level side-channel vulnerability that can leak upstream source port information under specific configurations, DNSSEC validation bypasses that can cause trust islands to be treated as insecure, and a performance degradation issue via chained compression pointers. These flaws can lead to cache poisoning, denial of DNS record existence, and degraded resolver performance. A fix is available in version 1.17.1-25.oe2403sp1.

References

Community reviews

Loading reviews…