Skip to main content
VulnerabilityPublished

CVE-2026-109125: unbound security update

Affects unboundSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-109125· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.13.2-31.oe2203sp4 when convenient.

Data as of 4 Nov 2026, 16:47 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (NLnet Labs)CVSS 3.15.3
Patch
Available – fixed in 1.13.2-31.oe2203sp4
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade unbound to 1.13.2-31.oe2203sp4.

Affected software

ProductAffectedFixed in
openEuler 22.03-LTS-SP4unboundpkg:rpm/openEuler/unbound&distro=openEuler-22.03-LTS-SP4Other threatsAffected
  • <1.13.2-31.oe2203sp4
Fixed in
  • 1.13.2-31.oe2203sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in Unbound version 1.13.2-31.oe2203sp4. Users should upgrade to this fixed version to mitigate the risks. The cache side-channel attack requires non-default configuration ('unwanted-reply-threshold' > 0), so default configurations are not vulnerable to this attack vector. No other specific mitigations are indicated by the vendor advisory.

Description

Multiple vulnerabilities affect NLnet Labs Unbound up to and including version 1.26.1. These include a cache-level side-channel vulnerability that can leak upstream source port information under specific non-default configurations, DNSSEC validation bypasses that can cause trust islands to be treated as insecure, and a resource exhaustion issue from chained compression pointers that can degrade performance. These issues can facilitate cache poisoning, denial of existence for DNS records, and performance degradation. A fix is available in version 1.13.2-31.oe2203sp4.

References

Community reviews

Loading reviews…