CVE-2026-115448: Apache ZooKeeper · Uncontrolled Recursion
Affects zookeeperSource GCVE Database
Not known to be exploited · CVSS 8.7 High.
Data as of 4 Nov 2026, 16:28 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 8.7 |
|---|
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.zookeeper/zookeeperpkg:maven/org.apache.zookeeper/zookeeperOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ZooKeeper to version 3.8.8 or 3.9.7, where this vulnerability is fixed. As a workaround, restrict znode creation permissions by configuring ACLs and authentication to prevent unauthorized creation of deeply nested znodes, rather than relying on the default open root ACL. No other specific mitigations are indicated.
Description
Apache ZooKeeper versions 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6 contain an uncontrolled recursion vulnerability during snapshot serialization. A client allowed to create znodes can create deeply nested znodes that exhaust the JVM stack when the server takes a snapshot, causing the snapshot thread to fail and resulting in a persistent denial of service. This failure recurs on server restart, potentially causing data loss and affecting the entire ensemble including leader and followers. Upgrading to versions 3.8.8 or 3.9.7 mitigates the issue. Restricting znode creation via ACLs and authentication is recommended as a workaround.