CVE-2026-120135: Apache Thrift Java bindings · Uncontrolled Recursion Vulnerability
Affects libthriftSource GCVE Database
Not known to be exploited · CVSS 8.2 High : upgrade to 0.24.0 soon.
Data as of 31 Oct 2026, 22:38 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 8.2 |
|---|
- Patch
- Available – fixed in 0.24.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade org.apache.thrift/libthrift to 0.24.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.thrift/libthriftpkg:maven/org.apache.thrift/libthriftOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Thrift to version 0.24.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.
Description
An uncontrolled recursion vulnerability exists in the Apache Thrift Java bindings affecting versions before 0.24.0. This flaw can lead to high-impact consequences if exploited. The issue has been addressed in Apache Thrift version 0.24.0, which users are advised to upgrade to.