Skip to main content
CVE-2024-1816VulnerabilityPublished Updated

CVE-2024-1816: GitLab · Uncontrolled Resource Consumption

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.1.1 : update gitlab when convenient.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.1.1, 17.0.3, 16.11.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade gitlab to 17.1.1, 17.0.3 or 16.11.5.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=12.0.0 <16.11.5
  • >=17.0.0 <17.0.3
  • >=17.1.0 <17.1.1
Fixed in
  • 16.11.5
  • 17.0.3
  • 17.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches available for GitLab CE/EE versions prior to 16.11.5, 17.0.3, and 17.1.1. Upgrading to fixed versions will mitigate the vulnerability. No additional mitigation steps are indicated.

Description

A vulnerability in GitLab CE/EE allows an attacker to cause denial of service via crafted OpenAPI files. This affects multiple version ranges from 12.0 up to but not including 16.11.5, 17.0 up to 17.0.3, and 17.1 up to 17.1.1. The issue results in uncontrolled resource consumption leading to service disruption. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…