Skip to main content
VulnerabilityPublished Updated

CVE-2024-4612: GitLab · Open Redirect

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.3.2 : update gitlab when convenient.

Data as of 26 Oct 2026, 10:12 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.3.2, 17.2.5, 17.1.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.3.2, 17.2.5 or 17.1.7.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=12.9.0 <17.1.7
  • >=17.2.0 <17.2.5
  • >=17.3.0 <17.3.2
Fixed in
  • 17.1.7
  • 17.2.5
  • 17.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade GitLab EE to versions 17.1.7, 17.2.5, or 17.3.2 or later to remediate the issue. Applying the official fixes will prevent exploitation of the open redirect vulnerability.

Description

GitLab EE contains an open redirect vulnerability (CVE-2024-4612) affecting versions from 12.9 up to but not including 17.1.7, 17.2 up to 17.2.5, and 17.3 up to 17.3.2. This flaw can break the OAuth flow under certain conditions, potentially allowing an attacker to take over user accounts. The vulnerability has been assigned medium severity. A patch is available to address this issue.

References

Community reviews

Loading reviews…