CVE-2026-60080: fory · Use After Free Vulnerability
Affects forySource GCVE Database
Not known to be exploited · CVSS 7.3 High · fixed in 1.4.0 : patch fory soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 21 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
crates.ioapache/forypkg:cargo/apache/foryOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Fory to version 1.4.0, which contains the official fix for this vulnerability. No other mitigation steps are indicated or required according to the vendor advisory.
Description
CVE-2026-60080 is a Use After Free vulnerability in the Rust deserialization logic of Apache Fory affecting versions from 0.13.0 through 1.3.0. A crafted payload can trigger undefined behavior, potentially causing process crashes or memory disclosure. The issue is fixed in version 1.4.0.