Skip to main content
VulnerabilityPublished

CVE-2026-53615: util-linux security update

Affects util-linuxSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.0 High : upgrade to 2.39.1-46.oe2403sp4 soon.

Data as of 29 Oct 2026, 11:03 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.39.1-46.oe2403sp4
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade util-linux to 2.39.1-46.oe2403sp4.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP4util-linuxpkg:rpm/openEuler/util-linux&distro=openEuler-24.03-LTS-SP4Other threatsAffected
  • <2.39.1-46.oe2403sp4
Fixed in
  • 2.39.1-46.oe2403sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the issue is fixed in util-linux version 2.41.4. Users and administrators should upgrade to this fixed version to remediate the vulnerability. No additional mitigation actions are specified or required beyond applying the official fix.

Description

A vulnerability in util-linux prior to version 2.41.4 allows a local attacker to craft a DOS extended-partition disk image or removable medium that causes libblkid to misreport partition metadata. This occurs due to improper 32-bit addition and missing bounds checks in the extended-partition parsing code, potentially leading to false partitions overlapping the MBR. The issue compromises the integrity of partition metadata, which could lead to disk modification or availability loss if downstream consumers act on the corrupted data. The flaw is fixed in util-linux version 2.41.4.

References

Community reviews

Loading reviews…