CVE-2026-39087: V2 · ntfy.sh allows a remote attacker to execute arbitrary code via the parseActions function
Affects heckel.io/ntfy/v2Source GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.22.0 as a priority.
Data as of 27 Oct 2026, 00:07 UTC
- Patch
- Available – fixed in 2.22.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade heckel.io/ntfy/v2 to 2.22.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Goheckel.io/ntfy/v2 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
An issue in Ntfy ntfy.sh before v.2.22.0 allows a remote attacker to execute arbitrary code via the parseActions function.
References
- nvd.nist.gov/vuln/detail/CVE-2026-39087 (opens in a new tab)
- gist.github.com/MightyNawaf/5d41d6e8ead16e217f86b016002ecae5 (opens in a new tab)
- github.com/binwiederhier/ntfy (opens in a new tab)
- github.com/binwiederhier/ntfy/releases/tag/v2.22.0 (opens in a new tab)
- ntfy.com (opens in a new tab)
- ntfysh.com (opens in a new tab)