Skip to main content
VulnerabilityPublished Updated

CVE-2025-64102: V2 · Zitadel allows brute-forcing authentication factors

Affects github.com/zitadel/zitadel/v2Source GCVE Database

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 2.71.18 soon.

Data as of 4 Nov 2026, 18:24 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.71.18, 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade github.com/zitadel/zitadel/v2 to 2.71.18; github.com/zitadel/zitadel to 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8.

Affected software

ProductAffectedFixed in
Gogithub.com/zitadel/zitadel/v2Affected
  • <2.71.18
Fixed in
  • 2.71.18
Gogithub.com/zitadel/zitadelAffected
  • <1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8
Fixed in
  • 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Zitadel to version 2.71.18 or later, 3.4.3 or later, or 4.6.0 or later to apply the official fix. The patch enforces lockout policies and introduces response delays to mitigate brute-force attacks. Alternatively, enabling the optional password maximum attempts lockout policy or implementing stricter rate limiting may reduce risk but can cause denial of service and are not full replacements for the patch.

Description

Zitadel versions 2.0.0 to 2.71.17, 3.0.0 to 3.4.2, and 4.0.0 to 4.4.0 are vulnerable to brute-force attacks on OTP, TOTP, and passwords. The vulnerability allows attackers to impersonate users by repeatedly attempting authentication factors. Although Zitadel supports a lockout mechanism to prevent brute-force attacks, it is not enabled by default and can cause denial of service if activated. The lockout policy was also not fully implemented in newer resource-based APIs. The issue has been fixed in versions 2.71.18, 3.4.3, and 4.6.0 by enforcing lockout policies and introducing a delay mechanism to slow down repeated failed attempts.

References

Community reviews

Loading reviews…