CVE-2025-48367: Valkey · Redis DoS Vulnerability due to bad connection error handling
Affects valkeySource GCVE Database
Not known to be exploited · fixed in 8.1.3 : patch valkey soon.
Data as of 26 Oct 2026, 06:15 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 67% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.1.3, 8.0.4, 7.2.10
Exploitation evidence
Disclosed: evidence found.
CVE published 16 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade valkey to 8.1.3, 8.0.4 or 7.2.10.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamivalkeypkg:bitnami/valkeyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to Redis versions 8.0.3, 7.4.5, 7.2.10, or 6.2.19 or later. Refer to the official Redis GitHub commit (https://github.com/redis/redis/commit/bde62951accfc4bb0a516276fd0b4b307e140ce2) for details. No additional mitigation is indicated by the vendor advisory.
Description
CVE-2025-48367 is a denial of service vulnerability in Redis caused by improper handling of connection errors. An unauthenticated connection can trigger repeated IP protocol errors, resulting in client starvation and service disruption. The issue affects multiple Redis versions and has been fixed in versions 8.0.3, 7.4.5, 7.2.10, and 6.2.19.
References
- github.com/redis/redis/commit/bde62951accfc4bb0a516276fd0b4b307e140ce2 (opens in a new tab)
- github.com/redis/redis/releases/tag/6.2.19 (opens in a new tab)
- github.com/redis/redis/releases/tag/7.2.10 (opens in a new tab)
- github.com/redis/redis/releases/tag/7.4.5 (opens in a new tab)
- github.com/redis/redis/releases/tag/8.0.3 (opens in a new tab)
- github.com/redis/redis/security/advisories/GHSA-4q32-c38c-pwgq (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-48367 (opens in a new tab)