Skip to main content
CVE-2025-49844VulnerabilityPublished Updated

CVE-2025-49844: Valkey · Redis Lua Use-After-Free may lead to remote code execution

Affects valkeySource GCVE Database

0

Not known to be exploited · public detection template (Nuclei) · 82% EPSS · fixed in 8.1.4 : patch valkey as a priority.

Data as of 26 Oct 2026, 08:30 UTC

Exploit forecast

Likely to be exploited

82.6% EPSS · Critical severity · No CVSS score from NVD or the CNA

EPSS
82.6% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.1.4, 8.0.6, 7.2.11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2025

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade valkey to 8.1.4, 8.0.6 or 7.2.11.

Affected software

ProductAffectedFixed in
Bitnamivalkeypkg:bitnami/valkeyOther threatsAffected
  • <7.2.11
  • >=8.0.0 <8.0.6
  • >=8.1.0 <8.1.4
Fixed in
  • 7.2.11
  • 8.0.6
  • 8.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the issue is fixed in Redis version 8.2.2. Users should upgrade to this version to fully remediate the vulnerability. As a temporary workaround, administrators can prevent execution of Lua scripts by restricting the EVAL and EVALSHA commands using Redis ACLs. This limits the attack surface until patching is performed.

Description

Redis versions 7.2.10 and earlier, 8.0.0 through 8.0.5, and 8.1.0 through 8.1.3 contain a use-after-free vulnerability in the Lua scripting engine. An authenticated user can exploit this by submitting a crafted Lua script that manipulates the garbage collector, potentially leading to remote code execution. This vulnerability is fixed in Redis version 8.2.2. As a workaround, administrators can restrict Lua script execution using ACLs to disable EVAL and EVALSHA commands.

References

Community reviews

Loading reviews…