Skip to main content
VulnerabilityPublished

CVE-2026-54498: ViewComponent · around_render HTML-Safety Bypass

Affects view_componentSource GCVE Database

0

Not known to be exploited · CVSS 8.7 High : upgrade to 4.12.0 soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.12.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade view_component to 4.12.0.

Affected software

ProductAffectedFixed in
RubyGemsview_componentAffected
  • >=4.0.0 <4.12.0
Fixed in
  • 4.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to view_component version 4.12.0 or later, where this vulnerability is fixed. No other mitigations are specified. Patch status is confirmed fixed in 4.12.0.

Description

A cross-site scripting (XSS) vulnerability exists in the view_component Ruby on Rails framework versions from 4.0.0 up to but not including 4.12.0. The issue arises because ViewComponent::Base#around_render can return HTML-unsafe strings that bypass normal escaping, and ViewComponent::Collection#render_in can mark combined output as safe, potentially exposing user-controlled data. This vulnerability is fixed in version 4.12.0.

References

Community reviews

Loading reviews…