Vikunja before 2.7.1 contains a credential exposure vulnerability that allows attackers to steal stored auth tokens by
Source GCVE Database
Not known to be exploited · CVSS 7.6 High : upgrade to 2.7.1 soon.
Data as of 8 Nov 2026, 06:49 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.6 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.8 |
- Patch
- Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade vikunja to 2.7.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| go-vikunjavikunja | Affected
| Fixed in
|
Govikunjapkg:golang/vikunjaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Vikunja to version 2.7.1 or later, where this vulnerability is fixed. Since the vulnerability is addressed in this version, applying the official fix is the recommended remediation.
Description
Vikunja versions prior to 2.7.1 have a credential exposure vulnerability that allows attackers to steal stored authentication tokens. This occurs when an attacker tricks a user into switching the frontend API URL, causing the application to send bearer tokens and OAuth refresh tokens to the attacker's server. This vulnerability can lead to account takeover.