Skip to main content
CVE-2026-123498VulnerabilityPublished

Vikunja veans before 2.7.1 contains a prompt injection vulnerability that allows project members with write access to

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123498· Low 2.1

Not known to be exploited · CVSS 2.1 Low : upgrade to 2.7.1 when convenient.

Data as of 8 Nov 2026, 07:02 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.1
CNA (VulnCheck)CVSS 3.13.7
Patch
Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade vikunja to 2.7.1.

Affected software

ProductAffectedFixed in
go-vikunjavikunjaAffected
  • <2.7.1
Fixed in
  • 2.7.1
Govikunjapkg:golang/vikunjaOther threatsAffected
  • <2.7.1
Fixed in
  • 2.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict write access to trusted project members only and monitor for suspicious project titles or task content that could contain malicious instructions.

Description

Vikunja veans versions before 2.7.1 have a prompt injection vulnerability that allows project members with write access to inject instructions via project titles or task content. These injected instructions are rendered verbatim inside the coding agent's authoritative instruction block, potentially causing the agent to modify developer checkouts or execute commands. The vulnerability has a low CVSS score of 3.7 and requires low privileges with user interaction.

References

Community reviews

Loading reviews…