Skip to main content
CVE-2024-41957VulnerabilityPublished Updated

Bundesamt für Sicherheit in der Informationstechnik Dell · vim: Mehrere Schwachstellen ermöglichen Denial of Service

Affects Bundesamt für Sicherheit in der Informationstechnik DellSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-41957· Medium 4.5

Not known to be exploited · CVSS 4.5 Medium : upgrade to 9.1.0647 when convenient.

Data as of 4 Nov 2026, 17:49 UTC

CVSS 3.1 base score
4.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.14.5
Patch
Available – fixed in 9.1.0647
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade vim/vim to 9.1.0647.

Affected software

ProductAffectedFixed in
GitHubvim/vimpkg:github/vim/vimOther threatsAffected
  • <9.1.0647
Fixed in
  • 9.1.0647

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches provided by Ubuntu by updating Vim to the fixed package versions listed for each supported Ubuntu LTS release. A standard system update will apply these fixes. Ubuntu Pro users have extended support for older releases. No additional mitigation is required beyond applying these updates.

Description

Multiple security vulnerabilities in Vim allow denial of service and potentially code execution when opening specially crafted files. These include a double-free vulnerability when closing a window and a use-after-free vulnerability when adding a file to an argument list. The issues affect various Ubuntu LTS releases and have been fixed in updated package versions.

References

Community reviews

Loading reviews…