CVE-2026-113723: virtualenv · Bash prompt values can change meaning under older compatibility modes
Affects pre-commitSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 4.7.0_1 or 2.20.0_1 soon.
Data as of 27 Oct 2026, 06:43 UTC
- Patch
- Available – fixed in 4.7.0_1, 2.20.0_1
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pre-commit to 4.7.0_1 or 2.20.0_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpre-commitpkg:brew/pre-commitOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in virtualenv versions 2.20.0_1 and 4.7.0_1. Users should upgrade to these or later versions to remediate the vulnerability. The vendor advisory confirms the fix and does not indicate any alternative mitigations or that no action is required. Users should avoid using older virtualenv versions with affected shells and ensure that prompt values passed to virtualenv are not attacker-controlled or sanitized.
Description
A vulnerability in virtualenv allows attacker-controlled prompt text to be interpreted as executable commands in certain older or less common shell compatibility modes. Specifically, when bash runs with compatibility level 4.2 or lower, or when dash shells inherit an exported PS1 prompt variable, the prompt text can be executed upon drawing the prompt. This occurs because the prompt string is expanded twice, and some paths do not properly escape the prompt text. The issue affects POSIX activation scripts generated by virtualenv versions prior to 2.20.0_1 and 4.7.0_1. The vulnerability requires an attacker to supply malicious prompt text and a user to activate the environment and interact with the shell prompt. A fix is available in virtualenv versions 2.20.0_1 and 4.7.0_1.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-6w3r-xr62-4xcp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113723 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3418 (opens in a new tab)
- github.com/pypa/virtualenv/commit/5f48d711731311428aebfae61d46957762155b22 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)