CVE-2026-102930: virtualenv · Downloaded seed wheels (pip/setuptools) are not integrity-checked before use
Affects pdmSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 2.29.2_1 or 2.9.3_2 soon.
Data as of 31 Oct 2026, 16:53 UTC
- Patch
- Available – fixed in 2.29.2_1, 2.9.3_2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pdm to 2.29.2_1 or 2.9.3_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpdmpkg:brew/pdmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patch by upgrading virtualenv to version 2.9.3_2 or later, or 2.29.2_1 or later, where SHA256 checksum verification of downloaded wheels is implemented. If using a custom package index, note that the integrity check is skipped by design. No other mitigations are recommended as the fix addresses the root cause.
Description
Virtualenv versions from 2.0.0 up to but excluding 2.9.3_2 and from 2.12.3 up to but excluding 2.29.2_1 do not verify the integrity of downloaded pip and setuptools wheels before use. This allows a compromised or malicious index, stale mirror, or man-in-the-middle attacker to substitute malicious wheels without detection. The issue is fixed by verifying the SHA256 checksum of downloaded wheels against PyPI's public JSON API, except when a custom index is used.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-94p9-xgh2-xp45 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-102930 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3251 (opens in a new tab)
- github.com/pypa/virtualenv/commit/a01ed3e2f239d6ab1fce62c5c7664ccf268fff6d (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/virtualenv/PYSEC-2026-4011.yaml (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.7.12 (opens in a new tab)
- pypi.org/project/virtualenv (opens in a new tab)